Cryptocurrency withdrawal delays

Minor incident Mobile App
2021-03-06 06:00 UTC · 13 hours, 52 minutes

Updates

Resolved

The withdrawal backlog has been processed.

November 4, 2021 · 15:25 UTC
Issue

Beginning approximately 10pm PT on Friday March 5th, we experienced delays with our cryptocurrency withdrawal processing system. All funds are secure. A fix has been implemented and the backlog of withdrawals are currently processing. We are actively monitoring.

November 4, 2021 · 15:25 UTC

← Back